Commit f04b5c39 authored by dkirov's avatar dkirov

check for pkg-config in autogen.sh

parent 1fcea905
......@@ -90,6 +90,7 @@ You will need GNU autotools in order to install Gajim from svn. This includes:
<li>autoconf &gt;= 2.59 </li>
<li>libtool</li>
<li>intltool-0.35.0 </li>
<li>pkgconfig &gt;= 0.19</li>
</ul>
</p>
steps to compile gajim:
......@@ -98,6 +99,11 @@ steps to compile gajim:
$ ./configure
$ make
</pre>
Alternatively, if you don't want to install all these packages, you can get a nightly snapshot from <a href="http://www.gajim.org/downloads/snap/">here</a> and procede as usual:
<pre>
$ ./configure
$ make
</pre>
<h2>Uninstallation Procedure</h2>
<p>
su -c make uninstall<br/>
......
......@@ -3,6 +3,11 @@
&& ls -1 -U data/gajim.desktop.in.in data/glade/*.glade \
src/*py src/common/*py src/common/zeroconf/*.py >> \
po/POTFILES.in || exit 1
if test -z `which pkg-config 2>/dev/null`;then
echo "***Error: pkg-config not found***"
echo "See README.html for build requirements."
exit 1
fi
set -x
intltoolize --force --automake \
&& aclocal -I ./m4 \
......
......@@ -7,6 +7,7 @@ AC_CONFIG_MACRO_DIR([m4])
AM_MAINTAINER_MODE
IT_PROG_INTLTOOL([0.35.0])
PKG_PROG_PKG_CONFIG([0.19])
AM_DISABLE_STATIC
AC_ENABLE_SHARED(yes)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment