Commit 7599a37d authored by Philipp Hörist's avatar Philipp Hörist

Check for required pygobject version

parent 7b9278ae
......@@ -29,6 +29,7 @@ from gajim.common import i18n
_MIN_NBXMPP_VER = "0.9.92"
_MIN_GTK_VER = "3.22.0"
_MIN_CAIRO_VER = "1.14.0"
_MIN_PYGOBJECT_VER = "3.32.0"
def _check_required_deps():
......@@ -43,6 +44,17 @@ def _check_required_deps():
'Quitting...' % _MIN_NBXMPP_VER)
sys.exit(1)
try:
import gi
except ImportError:
print('Gajim needs pygobject to run. Quitting…')
sys.exit(1)
if V(gi.__version__) < V(_MIN_PYGOBJECT_VER):
print('Gajim needs pygobject >= %s to run. '
'Quitting...' % _MIN_PYGOBJECT_VER)
sys.exit(1)
try:
import cairo
except ImportError:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment