Commit 70881971 authored by Yann Leboulanger's avatar Yann Leboulanger

update debian folder from 0.14 branch

parent 46b1b5db
...@@ -3,4 +3,7 @@ gajim for Debian ...@@ -3,4 +3,7 @@ gajim for Debian
If you want to use OpenPGP in gajim, you have to install python-gnupginterface. If you want to use OpenPGP in gajim, you have to install python-gnupginterface.
For video chat support, you have to install python-farsight.
-- Yann Le Boulanger <asterix@lagaule.org>, Mon, 20 Jun 2005 12:02:31 +0200 -- Yann Le Boulanger <asterix@lagaule.org>, Mon, 20 Jun 2005 12:02:31 +0200
-- Julien Valroff <julien@debian.org> Sat, 07 May 2011 13:50:27 +0200
gajim (0.13.90-1) unstable; urgency=low gajim (0.14.1-1) unstable; urgency=low
* New upstream release. [ Yann Leboulanger ]
* New upstream release. Closes: #604966
-- Yann Leboulanger <asterix@lagaule.org> Sat, 24 Jul 2010 10:25:26 +0200 * Correctly sanitize menuentries in chat window action context menu.
Closes: #574839
* Fix traceback when closing file request dialog. Closes: #587186
* Recommend python-openssl >= 0.9. Closes: #594772
* Improve a string. Closes: #553527
* Fix cancelling file transfer. Closes: #587679
[ Julien Valroff ]
* Switch to dh from CDBS and drop unused (build-)dependencies.
* Switch to dh_python2 from pysupport. Closes: #616819
* Drop useless debian/dirs.
* Switch to 3.0 (quilt) source format.
* Update Standards-Version to 3.9.2.
* Remove useless and unused shlibs:Depends substvar.
* Add a note about python-farsight in README.Debian.
* Add patch and use dh_autoreconf to remove build-dependencies on
python-dev, python-gtk2-dev and libgtk2.0-dev.
-- Yann Leboulanger <asterix@lagaule.org> Sat, 07 May 2011 16:01:37 +0200
gajim (0.13.4-1) unstable; urgency=low gajim (0.13.4-1) unstable; urgency=low
......
...@@ -2,19 +2,16 @@ Source: gajim ...@@ -2,19 +2,16 @@ Source: gajim
Section: net Section: net
Priority: optional Priority: optional
Maintainer: Yann Leboulanger <asterix@lagaule.org> Maintainer: Yann Leboulanger <asterix@lagaule.org>
Build-Depends: debhelper (>= 7), cdbs (>= 0.4.43), python-support (>= 0.7.1), python-dev, libgtk2.0-dev, python-gtk2-dev, gettext (>= 0.17-4), intltool (>= 0.40.1), imagemagick Build-Depends: debhelper (>= 7.0.50~), python (>= 2.6.6-3~), dh-autoreconf, gettext (>= 0.17-4), intltool (>= 0.40.1), imagemagick, libglib2.0-dev
Build-Conflicts: python2.3 Standards-Version: 3.9.2
XS-Python-Version: >= 2.5
Standards-Version: 3.8.3
Homepage: http://www.gajim.org Homepage: http://www.gajim.org
Vcs-Hg: http://hg.gajim.org/gajim/ Vcs-Hg: http://hg.gajim.org/gajim/
Vcs-Browser: http://hg.gajim.org/gajim/file Vcs-Browser: http://hg.gajim.org/gajim/file
Package: gajim Package: gajim
Architecture: all Architecture: all
XB-Python-Version: ${python:Versions} Depends: ${misc:Depends}, ${python:Depends}, python-gtk2 (>= 2.16.0), dnsutils
Depends: ${misc:Depends}, ${shlibs:Depends}, ${python:Depends}, python-support (>= 0.7.1), python-glade2 (>= 2.12.0), python-gtk2 (>= 2.12.0), dnsutils Recommends: dbus, python-dbus, notification-daemon, python-gnupginterface, python-openssl (>= 0.9), python-crypto
Recommends: dbus, python-dbus, notification-daemon, python-openssl, python-crypto
Suggests: python-gconf, python-gnome2, nautilus-sendto, avahi-daemon, python-avahi, network-manager, libgtkspell0, aspell-en, python-gnomekeyring, gnome-keyring, python-sexy, python-kerberos (>= 1.1), texlive-latex-base, dvipng, python-farsight, gstreamer0.10-plugins-ugly Suggests: python-gconf, python-gnome2, nautilus-sendto, avahi-daemon, python-avahi, network-manager, libgtkspell0, aspell-en, python-gnomekeyring, gnome-keyring, python-sexy, python-kerberos (>= 1.1), texlive-latex-base, dvipng, python-farsight, gstreamer0.10-plugins-ugly
Description: Jabber client written in PyGTK Description: Jabber client written in PyGTK
Gajim is a Jabber client. It has a tabbed user interface with normal chats, Gajim is a Jabber client. It has a tabbed user interface with normal chats,
......
...@@ -7,10 +7,9 @@ It was downloaded from: ...@@ -7,10 +7,9 @@ It was downloaded from:
Upstream Authors: Upstream Authors:
- Alexander Cherniuk <ts33kr@gmail.com> - Alexander Cherniuk <ts33kr@gmail.com>
- Yann Le Boulanger <asterix@lagaule.org> - Yann Le Boulanger <asterix@lagaule.org>
- Jonathan Schleifer <js-gajim@webkeks.org>
Copyright: (c) 2003-2010 Gajim Team Copyright: (c) 2003-2011 Gajim Team
This program is free software; you can redistribute it and/or modify This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by it under the terms of the GNU General Public License as published by
......
usr/bin
usr/share/gajim
usr/share/man/man1
usr/share/pixmaps
usr/share/applications
usr/share/menu
usr/share/lintian/overrides
usr/lib/gajim
Index: Makefile.am Description: don't install useless COPYING file
=================================================================== Forwarded: not-neded
--- Makefile.am (revision 7202)
+++ Makefile.am (working copy) --- a/Makefile.am
@@ -9,7 +9,6 @@ +++ b/Makefile.am
@@ -8,7 +8,6 @@
docfiles_DATA = README \ docfiles_DATA = README \
README.html \ README.html \
ChangeLog \ ChangeLog \
- COPYING \ - COPYING \
THANKS \ THANKS \
THANKS.artists \
AUTHORS AUTHORS
--- a/Makefile.in
--- Makefile.in +++ b/Makefile.in
+++ Makefile.in @@ -299,7 +299,6 @@
@@ -273,7 +273,6 @@
docfiles_DATA = README \ docfiles_DATA = README \
README.html \ README.html \
ChangeLog \ ChangeLog \
- COPYING \ - COPYING \
THANKS \ THANKS \
THANKS.artists \
AUTHORS AUTHORS
Description: don't require python headers to remove build-dep on python-dev and python-gtk2-dev
Author: Yann Leboulanger <asterix@lagaule.org>
Origin: upstream,http://hg.gajim.org/gajim/diff/252bb3cf2c59/configure.ac
Last-Update: 2011-05-07
--- a/configure.ac
+++ b/configure.ac
@@ -36,25 +36,10 @@
AM_NLS
-dnl ****
-dnl pygtk and gtk+
-dnl ****
-PKG_CHECK_MODULES([PYGTK], [gtk+-2.0 >= 2.16.0 pygtk-2.0 >= 2.16.0])
-AC_SUBST(PYGTK_CFLAGS)
-AC_SUBST(PYGTK_LIBS)
-PYGTK_DEFS=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
-AC_SUBST(PYGTK_DEFS)
-
-AM_PATH_PYTHON([2.5])
-if test "x$PYTHON" = "x:"; then
- AC_MSG_ERROR([Python not found])
-fi
-
ACLOCAL_AMFLAGS="\${ACLOCAL_FLAGS}"
AC_SUBST(ACLOCAL_AMFLAGS)
-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
-AC_SUBST([PYTHON_INCLUDES])
+AM_PATH_PYTHON([2.5])
dnl ****
dnl enable installation in python-2.x/site-packages/gajim
00_debian-copying.diff
01_configure-ac.diff
#!/usr/bin/make -f #!/usr/bin/make -f
DEB_PYTHON_SYSTEM=pysupport
# Debhelper must be included before python-distutils to use %:
# # # dh_python / dh_pycentral / dh_pysupport dh $@ --with python2,autoreconf
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/cdbs/1/class/autotools.mk
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/usr # test target is broken
DEB_MAKE_BUILD_TARGET := all override_dh_auto_test:
DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
binary-install/gajim:: override_dh_auto_configure:
dh_pysupport -pgajim convert icons/hicolor/64x64/apps/gajim.png -resize 32x32 debian/gajim.xpm
convert $(DEB_DESTDIR)/usr/share/icons/hicolor/64x64/apps/gajim.png -resize 32x32 $(DEB_DESTDIR)/usr/share/pixmaps/gajim.xpm dh_auto_configure
override_dh_auto_install:
dh_auto_install
rm debian/gajim/usr/share/gajim/src/common/GnuPGInterface.py*
override_dh_auto_clean:
-rm -f debian/gajim.xpm
dh_auto_clean
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment