Commit 0d4ba654 authored by Philipp Hörist's avatar Philipp Hörist

Make idna and precis-18n required dependencys

parent 2c01883f
...@@ -11,7 +11,8 @@ ...@@ -11,7 +11,8 @@
- python3-openssl (>=0.14) - python3-openssl (>=0.14)
- python3-cssutils (>=1.0.2) - python3-cssutils (>=1.0.2)
- python3-keyring - python3-keyring
- python3-idna
- python3-precis-i18n
### Optional Runtime Requirements ### Optional Runtime Requirements
...@@ -25,7 +26,6 @@ ...@@ -25,7 +26,6 @@
- gir1.2-gupnpigd-1.0 for better NAT traversing - gir1.2-gupnpigd-1.0 for better NAT traversing
- gir1.2-networkmanager-1.0 for network lose detection - gir1.2-networkmanager-1.0 for network lose detection
- gir1.2-geoclue-2.0 for sharing your location - gir1.2-geoclue-2.0 for sharing your location
- python3-idna and python3-precis-i18n for correctly parsing JIDs
### Compile-time Requirements ### Compile-time Requirements
......
...@@ -287,6 +287,8 @@ setup( ...@@ -287,6 +287,8 @@ setup(
'keyring', 'keyring',
'nbxmpp>=0.6.8', 'nbxmpp>=0.6.8',
'pyOpenSSL>=0.12', 'pyOpenSSL>=0.12',
'cssutils>=1.0.2' 'cssutils>=1.0.2',
'precis-i18n>=1.0.0',
'idna>=2.7',
] ]
) )
...@@ -103,6 +103,7 @@ python-axolotl ...@@ -103,6 +103,7 @@ python-axolotl
qrcode qrcode
cssutils cssutils
precis-i18n precis-i18n
idna
" "
build_pip install $(echo "$PIP_REQUIREMENTS" | tr ["\\n"] [" "]) build_pip install $(echo "$PIP_REQUIREMENTS" | tr ["\\n"] [" "])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment