Commit 7cbf2314 authored by Philipp Hörist's avatar Philipp Hörist

Depend on GLib >= 2.60.0

Fixes #10125
parent 3fa94240
Pipeline #5674 passed with stages
in 3 minutes and 8 seconds
......@@ -14,6 +14,7 @@
- python3-precis-i18n
- python3-packaging
- gir1.2-soup-2.4
- GLib > 2.60.0
### Optional Runtime Requirements
......
......@@ -30,12 +30,13 @@ _MIN_NBXMPP_VER = '0.9.94'
_MIN_GTK_VER = '3.22.27'
_MIN_CAIRO_VER = '1.16.0'
_MIN_PYGOBJECT_VER = '3.32.0'
_MIN_GLIB_VER = '3.60.0'
def check_version(dep_name, current_ver, min_ver):
if V(current_ver) < V(min_ver):
sys.exit('Gajim needs %s >= %s to run. '
'Quitting...' % (dep_name, min_ver))
sys.exit('Gajim needs %s >= %s (found %s) to run. '
'Quitting...' % (dep_name, min_ver, current_ver))
def _check_required_deps():
......@@ -71,11 +72,17 @@ def _check_required_deps():
Gtk.get_minor_version(),
Gtk.get_micro_version())
from gi.repository import GLib
glib_ver = '.'.join(map(str, [GLib.MAJOR_VERSION,
GLib.MINOR_VERSION,
GLib.MICRO_VERSION]))
check_version('python-nbxmpp', nbxmpp.__version__, _MIN_NBXMPP_VER)
check_version('pygobject', gi.__version__, _MIN_PYGOBJECT_VER)
check_version('libcairo', cairo.cairo_version_string(), _MIN_CAIRO_VER)
check_version('python-cairo', cairo.version, _MIN_CAIRO_VER)
check_version('gtk3', gtk_ver, _MIN_GTK_VER)
check_version('glib', glib_ver, _MIN_GLIB_VER)
def _init_gui(gui):
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment