Commit 779a4d4c authored by Philipp Hörist's avatar Philipp Hörist
Browse files

Get version from package instead of config

parent a937b0a5
......@@ -34,6 +34,7 @@
import configparser
from pkg_resources import parse_version
import gajim
from gajim.common import app
from gajim.common import nec
from gajim.common import configpaths
......@@ -536,7 +537,7 @@ def scan_dir_for_plugins(path, scan_dirs=True, package=False):
min_v = conf.get('info', 'min_gajim_version', fallback=None)
max_v = conf.get('info', 'max_gajim_version', fallback=None)
gajim_v = app.config.get('version').split('+', 1)[0]
gajim_v = gajim.__version__.split('+', 1)[0]
gajim_v_cmp = parse_version(gajim_v)
if min_v and gajim_v_cmp < parse_version(min_v):
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment