Commit e5defb7e authored by André's avatar André

Flatpak: Update dependencies and plugin versions

parent c8af6118
name: python3-pillow
ensure-writable:
- easy-install.pth
buildsystem: simple
build-commands:
- install -d ${FLATPAK_DEST}/lib/python3.7/site-packages/
- python3 setup.py install --prefix=${FLATPAK_DEST}
- pip3 install --prefix=${FLATPAK_DEST} .
sources:
- type: archive
url: https://files.pythonhosted.org/packages/1b/e1/1118d60e9946e4e77872b69c58bc2f28448ec02c99a2ce456cd1a272c5fd/Pillow-5.3.0.tar.gz
sha256: 2ea3517cd5779843de8a759c2349a3cd8d3893e03ab47053b66d5ec6f8bc4f93
url: https://files.pythonhosted.org/packages/3c/7e/443be24431324bd34d22dd9d11cc845d995bcd3b500676bcf23142756975/Pillow-5.4.1.tar.gz
sha256: 5233664eadfa342c639b9b9977190d64ad7aca4edc51a966394d7e08e7f38a9f
id: org.gajim.Gajim.Plugin.omemo
runtime: org.gajim.Gajim
sdk: org.gnome.Sdk//3.30
sdk: org.gnome.Sdk//3.32
build-extension: true
separate-locales: false
appstream-compose: false
......@@ -16,32 +16,27 @@ modules:
buildsystem: simple
build-commands:
- install -d ${FLATPAK_DEST}/lib/python3.7/site-packages/
- pip3 install --prefix=${FLATPAK_DEST} protobuf-3.6.1-py2.py3-none-any.whl
- pip3 install --prefix=${FLATPAK_DEST} protobuf-3.7.0-py2.py3-none-any.whl
sources:
- type: file
url: https://files.pythonhosted.org/packages/77/78/a7f1ce761e2c738e209857175cd4f90a8562d1bde32868a8cd5290d58926/protobuf-3.6.1-py2.py3-none-any.whl
sha256: 196d3a80f93c537f27d2a19a4fafb826fb4c331b0b99110f985119391d170f96
url: https://files.pythonhosted.org/packages/41/7c/6029e1b37ca730648a22502d75e2c7707da7a207db1b366f76edc5a01a0b/protobuf-3.7.0-py2.py3-none-any.whl
sha256: e47d248d614c68e4b029442de212bdd4f6ae02ae36821de319ae90314ea2578c
- name: python3-axolotl-curve25519
ensure-writable:
- easy-install.pth
buildsystem: simple
build-commands:
- install -d ${FLATPAK_DEST}/lib/python3.7/site-packages/
- python3 setup.py install --prefix=${FLATPAK_DEST}
- pip3 install --prefix=${FLATPAK_DEST} .
sources:
- type: archive
url: https://files.pythonhosted.org/packages/59/ca/c8111718bcc8da18e9b9868e784293232a58c57159a5ea18f00ee967258f/python-axolotl-curve25519-0.4.1.post2.tar.gz
sha256: 0705a66297ebd2f508a60dc94e22881c754301eb81db93963322f6b3bdcb63a3
- name: python3-axolotl
ensure-writable:
- easy-install.pth
- setuptools.pth
buildsystem: simple
build-commands:
- install -d ${FLATPAK_DEST}/lib/python3.7/site-packages/
- python3 setup.py install --prefix=${FLATPAK_DEST}
- pip3 install --prefix=${FLATPAK_DEST} .
sources:
- type: archive
url: https://files.pythonhosted.org/packages/27/99/3b905f0061aba53526408d286e53cee3b00c9fd256eed7d21d5d41033690/python-axolotl-0.1.42.tar.gz
......@@ -51,11 +46,11 @@ modules:
buildsystem: simple
build-commands:
- install -d ${FLATPAK_DEST}/lib/python3.7/site-packages/
- pip3 install --prefix=${FLATPAK_DEST} qrcode-6.0-py2.py3-none-any.whl
- pip3 install --prefix=${FLATPAK_DEST} qrcode-6.1-py2.py3-none-any.whl
sources:
- type: file
url: https://files.pythonhosted.org/packages/79/be/11999004f7e6e5db0fa410c2feacd67c07f472f4500fde0026101f31d0df/qrcode-6.0-py2.py3-none-any.whl
sha256: de4ffc15065e6ff20a551ad32b6b41264f3c75275675406ddfa8e3530d154be3
url: https://files.pythonhosted.org/packages/42/87/4a3a77e59ab7493d64da1f69bf1c2e899a4cf81e51b2baa855e8cc8115be/qrcode-6.1-py2.py3-none-any.whl
sha256: 3996ee560fc39532910603704c82980ff6d4d5d629f9c3f25f34174ce8606cf5
- name: gajim-omemo
buildsystem: simple
......@@ -66,8 +61,8 @@ modules:
- appstream-compose --basename=org.gajim.Gajim.Plugin.omemo --prefix=${FLATPAK_DEST} --origin=flatpak org.gajim.Gajim.Plugin.omemo
sources:
- type: archive
url: https://ftp.gajim.org/plugins_releases/omemo_2.6.1.zip
sha256: 52900457b10c55c2a7e4f67bb17861a1d769f909819e464fc3503842defb4b7f
url: https://ftp.gajim.org/plugins_releases/omemo_2.6.53.zip
  • This is all built for Gajim's 1.1 branch, right? The OMEMO plugin on gajim-plugins 1.1 branch is on version 2.6.28 (are you bundling a master branch plugin version here?).

Please register or sign in to reply
sha256: 296a2add78ec1af0471528c4cc2e088933e103b27899d2569c67c48ef2118339
- type: file
path: org.gajim.Gajim.Plugin.omemo.metainfo.xml
sha256: d7ef976ee4239d5c6b0da7b5e3bcc85d99db7d860c0329347a9522e8a176c69e
id: org.gajim.Gajim.Plugin.url_image_preview
runtime: org.gajim.Gajim
sdk: org.gnome.Sdk//3.30
sdk: org.gnome.Sdk//3.32
build-extension: true
separate-locales: false
appstream-compose: false
......@@ -21,8 +21,8 @@ modules:
- appstream-compose --basename=org.gajim.Gajim.Plugin.url_image_preview --prefix=${FLATPAK_DEST} --origin=flatpak org.gajim.Gajim.Plugin.url_image_preview
sources:
- type: archive
url: https://ftp.gajim.org/plugins_releases/url_image_preview_2.3.1.zip
sha256: b90d50f5e7aaa46f8eff8bf531a98f208e48e771ac81b3d36a23d44ae13a0500
url: https://ftp.gajim.org/plugins_releases/url_image_preview_2.3.33.zip
sha256: 1fc35508a0a63199a45e524181ee497986a357908e9591814a30248f6c583e03
- type: file
path: org.gajim.Gajim.Plugin.url_image_preview.metainfo.xml
sha256: 3b11c6bcb9c349bb6b831031da6740f5da6fc1e925ab98c5c06a62d787ca26fc
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment