Commit c959602a authored by Apromixately's avatar Apromixately Committed by Philipp Hörist

[plugin_installer] Improve manifest error message

parent 4c3c4a2a
......@@ -395,8 +395,11 @@ class DownloadAsync(threading.Thread):
continue
opts = config.options('info')
if not set(MANDATORY_FIELDS).issubset(opts):
log.warning('Plugin is missing mandatory fields in manifest.ini. '
'Plugin not loaded.')
log.warning(
'%s is missing mandatory fields %s. '
'Plugin not loaded.',
filename,
set(MANDATORY_FIELDS).difference(opts))
continue
# Add icon and remote dir
icon = None
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment