Commit 6447da9c authored by Philipp Hörist's avatar Philipp Hörist

[pgp] Fix dependency check

parent a70e4f12
......@@ -36,7 +36,13 @@ from gajim.plugins import GajimPlugin
log = logging.getLogger('gajim.plugin_system.oldpgp')
ERROR_MSG = ''
if not app.HAVE_GPG:
if hasattr(app, 'HAVE_GPG'):
# Gajim 1.0.0
HAVE_GPG = app.HAVE_GPG
else:
# Gajim 1.0.3+
HAVE_GPG = app.is_installed('GPG')
if not HAVE_GPG:
if os.name == 'nt':
ERROR_MSG = _('Please install GnuPG / Gpg4win')
else:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment